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Your First Maya Animation

In this chapter you’re going to start using Maya software and make some things

move. You’ve spent some time learning how the Maya interface works and how some 

of the windows operate, and that’s really all you need to know to get started. This chapter

will take you through the creation of the solar system and the mechanics of animating

orbits. With the solar system exercise, you’ll dive into creating simple objects, setting 

simple keyframes, and stacking your animation to get planets and moons to orbit each

other and the sun. This will expose you to object creation, simple modeling, object com-

ponents, grouping and hierarchies, basic keyframing, and basic timing. Topics include:

■ Project Overview: the Solar System

■ The Preproduction Process: Planning

■ Creating a Project

■ The Production Process: Creating and Animating the Objects

■ Using the Outliner
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Project Overview: The Solar System
This project focuses on familiarizing you with the fundamentals of object creation, hierarchy,

and pivots. You will create and animate a simple simulation of our working solar system.

This tutorial is good practice for getting used to object hierarchies and selections. It will

show you how to set up hierarchies and give you experience in working with the proper

nodes within a group to create hierarchically layered animation.

The focus in this example is getting used to working with objects.

The Preproduction Process: Planning
As with any good animation, you need to begin with a good plan. The more research and

information you gather, the better equipped you’ll be. For this simple animation, you’ll

need to find out where each of the nine planets are in relation to the sun and each other,

how they orbit, and how many moons they have.

Starting with the sun in the center, the planets in order are Mercury, Venus, Earth,

Mars, Jupiter, Saturn, Uranus, Neptune, and Pluto. They all orbit the sun in ellipses, but

you’ll be fine with circular orbits for this exercise. Most planets have a number of moons

that orbit them, and one has a large ring that circles around it.

Earth 1 moon

Mars 2 small moons

Jupiter 16+ moons

Saturn 3 large rings and 18+ moons

Uranus 18 moons

Neptune 8 moons

Pluto 1 moon

It may seem overwhelming to create and animate all those objects, but it’s a fantastic

exercise in getting comfortable with Maya animation. Since the essence of the project is

attainable without making every moon, you’ll cut most of them out of your scene.

Creating a Project
Start by creating a new project for this assignment. Choose File ➔ Project ➔ New to open

the New Project window. (Figure 3.1 shows the Windows version; the Mac OS X version

has the same fields.) In the Maya software, files are organized in a particular way. The top

level of this organization is the project folder. Within the project folder are numerous file

folders that hold your files. The two that stand out are the Scenes and Images folders. The

Scenes folder stores your scene files, which contain all the information for your scene, and

the Images folder stores images you’ve rendered out from your scene.

The scene files mentioned in this chapter are all included on the CD in a project layout explained

here. You can copy the scene files into your own project folders once you create the project.
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To create a new project, follow these steps:

1. In the Name field in the New Project window, enter Solar_System as the name for your

project. In the Location box, type the location where you want to store your projects.

The default location for Windows is My Documents\maya\projects; for Macs, the

default location is Home (/Users/<yourname>) in the Documents/maya/projects/default

folder. If you prefer, you can put projects in a folder on your second hard drive to

keep them separate from your operating system; this allows for easier backup and is

generally a safer environment.

2. On a Windows system, create a folder called Projects (on drive D, for example) through

Windows Explorer. On a Mac, select the second drive from the Choose a Folder dialog

box (drag the bottom slider all the way to the left to display all your attached and net-

worked hard drives) and create a folder in it called Projects. In the New Project window,

click the Browse button and select D:\Projects (Windows) or <Hard Drive Name>/Projects

(Mac) for the location. All the other fields will be filled in for you with defaults; just

click the Use Defaults button. Click Accept to create the necessary folders in your speci-

fied location. Figure 3.2 shows the complete New Project window in Windows; except

for the drive name, the values are the same on a Macintosh.

Figure 3.2

The completed New Project window

Figure 3.1

The New Project window on a Windows
system. Maya automatically creates a new
file system structure for your project.

creating a project ■ 61

4353c03.qxd  6/2/04  4:31 PM  Page 61



How much disk space you require depends on the project. Depending on the complex-

ity and extent of your models and animation, your scene files will typically be small. Real

disk space starts being consumed when you render out hundreds of frames at a time.

You’ll need about 10–15MB free for this project.

The Production Process: Creating
and Animating the Objects
As discussed in Chapter 1, production is typically divided into phases to make workflow

easier to manage. In this project, you’ll first create the sun, the planets, and their moons;

then you’ll animate their respective orbits and rotations.

Creating the Sun and the Planets
The first thing we’re going to do is create the sun and the planets. Follow these steps:

1. Choose File ➔ New Scene. Maya will ask if you want to save your current scene. Save

the file if you need to, or click No to discard the scene.

2. In the four-panel view, press the spacebar with the cursor inside the top view panel to

select and maximize it. (By default, Maya starts with the single perspective view. If

that’s the case, press the spacebar to toggle back into the four-panel view first, and

then select the top view to maximize it.)

3. To create the sun, choose Create ➔ NURBS Primitives ➔ Sphere. This will place a

NURBS sphere at the origin—that is at a position of 0,0,0 for X,Y,Z. The origin of the

workspace will be the center of the solar system.

4. Select nurbsSphere1 in the Channel Box, and type Sun.

Keep in mind that Maya is case-sensitive. An object named sun is different from an

object named Sun.

Naming your objects right after creation is a good habit to establish. It makes for a cleaner

scene file and a more organized workspace. These are particularly important if anyone needs

to alter your scene file.

After you create projects, you can switch between them by choosing File ➔ Project ➔ Set and

selecting the new project. Maya then uses that project’s folders until you switch to or create

another project.
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5. Press R to activate the scale manipulator and uniformly scale it up to about twice its

current size. For more precision, you can instead highlight the entry fields (the white

window next to the attribute) for the Scale X, Scale Y, and Scale Z channels in the

Channel Box and enter the 4 in any of the three fields. A scale of 4 will be entered in

all three fields, as shown in Figure 3.3, and your sun will expand in size by a factor 

of 4. Entering exact values in the Channel Box is a way to scale the sphere precisely.

Using the manipulator does the same job but may not be as precise.

Creating the Planets

Next create the planets. Follow these steps:

1. Create a NURBS sphere for Mercury and name it as such.

2. Press W to activate the move manipulator, and move Mercury a few grid units away

from the sun in the positive X direction. (Click the red arrow and drag it to the right.)

Leave about two grid units between Mercury and the sun.

3. Since Mercury is the second smallest planet and is tiny compared with the sun, scale it

down to 1/20 the size of the sun, or 0.2 in all three axes of scale.

4. Repeat steps 1 through 3 to create the rest of the planets and line them up, each pro-

gressively farther out in the X axis. Be sure to keep about two grid units of space

between each of them. Scale each one to be proportional as follows:

Venus 0.5

Earth 0.5

Mars 0.4

Jupiter 1.0

Saturn 0.9

Uranus 0.7

Neptune 0.7

Pluto 0.15

Now of course this is not a precise proportion to the solar system, but it will do nicely

here. Figure 3.4 shows how your solar system should look now.

Figure 3.4

Top view—all the
NURBS spheres lined
up in place
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The sun’s Scale values
in the Channel Box
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Using Snaps

This would be the perfect time to start using snaps, the icons you looked at in the 

previous chapter.

Icon Name Description

Snap to Grids Snaps objects to intersections of the view’s grid

Snap to Curves Snaps objects along a curve

Snap to Points Snaps objects to object points such as CVs or vertices

Snap to View Planes Snaps objects to view planes

You use snaps to snap objects into place with precision, by placing them by their pivot

points directly onto grid points, onto other object pivots, onto curve points, and so on.

Here you will slightly reposition all the planets to center them on the nearest grid line

intersection. Follow these steps:

1. Select the first planet, Mercury, and toggle on the grid snaps by clicking the grid 

snap icon: .

2. The center of the move manipulator turns from a square to a circle, signaling that some

form of snapping is active. Grab the manipulator in the middle by this circle, and move

it slightly to the left or right to snap it onto the closest grid intersection on the X axis.

3. Select the remaining planets, and snap them all to the closest grid intersection on the

X axis, making sure to keep about two grid spaces between each of them. Since the

sun was created at the origin, and you haven’t moved it, you don’t need to snap it

onto an intersection.

Making Saturn’s Ring

You will now create the ring for your Saturn. Follow these steps:

1. Choose Create ➔ NURBS Primitives ➔ Torus to get a donut shape. Snap the ring to

the same grid intersection as Saturn. This will ensure that both the planet and its ring

are on the same pivot point; they share the same center.

2. Select the torus shape you’ve created, and name it Ring (if you haven’t already done so).

3. While the torus shape is still selected, press the spacebar to display the four-panel lay-

out, and maximize the perspective window.

4. Press F to focus the perspective display on the ring—and on Saturn as well.

5. Press 5 to get into shaded mode, and with the torus selected, press 3 to increase the

resolution display for the ring.

6. Press R to display the scale manipulator, and scale it down to 0 or close to 0 in the Y

axis to flatten it.
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S A V I N G  M U L T I P L E  V E R S I O N S  O F  Y O U R  W O R K  A N D  I N C R E M E N T A L S A V E

As you’re working on a project, you may want to save multiple versions of your files at various stages of completion.

When working in the professional world, you’ll find that clients and art directors often reconsider animations you’ve

created, so it’s always good to keep as many versions of an animation as you can. Scene files are reasonably small,

and hard disk space is inexpensive. Just keep your scene folder organized well—for example, by keeping older ver-

sions of scenes in separate subfolders—and you should have no problems.

Maya 6’s incremental save feature is a valuable tool for saving multiple stages of your work, and you may wish to

use it as you work through the tutorial projects in this book. Once you’ve turned on this feature, you can use it to

save and create a backup at any stage in your work. If you need to take a break before the instructions tell you to

save, you’ll be able to start again with the most recent version of your scene file.

Incremental save makes a backup of your scene file every time you save it. To enable it, choose File ➔ Save Scene ❒

and click the Incremental Save option box. Once you’ve done this, Maya creates a new folder within your Scenes

folder with the name of your current scene file. It then creates a backup of your scene in that folder and appends a

number to the filename; for example, planets_001.mb. Every time you save your file, Maya creates a new backup.

Once you enable incremental save, Maya continues to keep the option turned on until you disable it through File ➔

Save Scene ❒.

The scene files for the projects in this book are provided on the accompanying CD to give you a reference point

for the major stages of each project; compare your own version to those files to make sure you’re following the

instructions correctly. (In later chapters, some projects also begin with a scene file from the CD.) These files use a

slightly different naming system than the names generated by incremental save (for example, planets_v1.mb

instead of planets_001.mb), and there is no risk of files overwriting each other.

For important real-world projects, you may decide to supplement the incremental save backups by using Save

Scene As to create manually named files, perhaps following a similar naming system, at the stages where you’ve

made significant changes. This may make it easier to identify specific versions of a scene for comparison. Whether

you do this or use incremental save, it’s a good idea to keep written notes about the differences in each version of a

scene file; so whenever you make a significant change to a file, you have a record of your work. (If you do name files

manually, be sure to use an underscore (_) between the filename and version number instead of a space. Using

spaces in your filenames can create problems with the software and with the operating system, especially when

you’re rendering out a scene.)

You’ll notice that the ring is too fat and is cutting into the planet. You need to edit the

attributes of the ring to increase the inside radius of the donut shape and create a gap

between the planet and the ring.

7. Press Ctrl+A to open the Attribute Editor, and then click the makeNurbTorus1 tab to

select its creation node. (See Figure 3.5.)
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8. Increase the Radius attribute to about 1.5 and decrease the Height Ratio attribute to

about 0.25 to get the desired effect.

Now all your planets are complete, and you can move on to the moons.

Saving Your Work
Now save your work. Saving frequently is a critical habit to establish. Power failures and

other unforeseen circumstances may not happen often, but they do happen. (As men-

tioned in the sidebar on the previous page, Maya’s incremental save feature makes it easy

to maintain backups of each stage of your work.) Because you created this as a new proj-

ect, the Save File window will direct you to the Scenes folder of that project. Save your

scene as planets in .mb (Maya Binary) format. (If you’re working in Maya PLE, you can

only save your files as .mp files.)

The file Planets_v1.mb in the Scenes folder of the Solar_System project on the CD

shows what the scene should look like at this point.

Creating the Moons
For the planets with moons, create a new NURBS sphere for each moon. For simplicity’s sake,

create a maximum of only two moons for any planet. However, to get more comfortable with

this exercise, feel free to make all the moons for all the planets.

The first moon will be Earth’s. Use the top view to follow these steps:

1. Create a NURBS sphere and scale it to about half the size of Earth

using the scale manipulator. There’s really no need to type any 

values for any of the moons’ sizes; you can just visually estimate

their sizes.

2. Move the sphere to within half a unit of Earth using the move

manipulator by the X axis. There’s no need to snap it to a grid

point, so toggle off the Snap to Grid icon ( ).

3. Repeat steps 1 and 2 for the remaining moons, placing them each

within half a grid unit from their respective planets. When you cre-

ate two moons for a planet, place one on either side of the planet.

4. Once you’re done with all the moons and their placements and

sizes, select all the elements in the scene and press 3 to increase 

the display resolution on all the spheres. When you’re done, you

should have a scene similar to Figure 3.6 in perspective view.

Changing the original attributes or parameters of an object as you’ve just done with Saturn’s

ring is often referred to as parametric modeling.
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Changing the creation attributes of the
NURBS torus in the Attribute Editor
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Applying a Simple Shader
To help distinguish one gray planet from another, attach simple

shaders to each of the planets. You can easily take care of this

task using the Hypershade window. Follow these steps:

1. Choose Window ➔ Rendering Editors ➔ Hypershade to

open the Hypershade window. You will notice three default

(or initial) shader icons already loaded. (See Figure 3.7.)

2. In the Create Maya Nodes Panel on the left of the Hyper-

shade window and under the Surface heading, click the

Lambert icon (a gray sphere) to create a new Lambert

shader node. It will appear in the top and bottom of the

Hypershade window. Click it another eight times to create a

total of nine Lambert shading groups in the Hypershade

window.

re 3.6

planets and
ns in position in
pective view
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The Hypershade
window
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3. Click the first of the new Lambert nodes (lambert2) in the Hypershade window, and

then double-click its icon to open the Attribute Editor. At the top, replace lambert2

with Mercury_Color to identify this material as the one you will use for Mercury.

4. Name each of the remaining eight planets in your animation (Venus, Earth, Mars,

Jupiter, Saturn, Uranus, Neptune, and Pluto).

Again, keeping a well-named and organized scene is paramount in a smooth animation

experience. It’s so much more of a chore to root through dozens of unnamed nodes to

find the one you want. When you’re done with naming all the material nodes, save your

work. You may want to take a break.

Once you’ve created the shaders, you can assign the appropriate colors to each of them

according to the planet they represent.

1. Double-click Mercury to open its Attribute Editor if it’s not currently open (see 

Figure 3.8).

2. To change the color of the shader, click the gray box next to the Color attribute. This

opens the Color Chooser window, from which you can choose a new color from the

color wheel or by adjusting values with the HSV sliders. Since Mercury has a brown-

ish red appearance, go with an orange such as in Figure 3.9.

S E T T I N G  K E Y F R A M E S

As with many other functions in Maya, you can set a keyframe in several ways. The best

way when you’re first starting to learn Maya is to choose Animate ➔ Set Key ❒ to display the

Set Key Options dialog box:

If you simply choose Animate ➔ Set Key instead, Maya sets a keyframe for every single

keyable attribute for the selected object. Although this may seem convenient, it makes for 

a sloppy scene, especially if the scene must be heavily animated.

Having keyframes for attributes that may not actually be animated creates unnecessary

clutter. In the Set Key Options dialog box, set the Set Keys On to All Keyable Attributes

instead of the default All Manipulator Handles and Keyable Attributes.

Set Channels to From Channel Box instead of the default All Keyable.

Now, when you choose Animate ➔ Set Key, you will set only a key-

frame for the channels that you specify explicitly through the Channel

Box, giving you greater control and efficiency. All you have to do is

highlight the channel you want to keyframe and then choose Ani-

mate ➔ Set Key. Save your settings by choosing Edit ➔ Save Settings,

and then click Close to close the dialog box.

To rename a node in the Hypershade window, you can also right-click the node’s icon and

choose Rename from the shortcut menu that appears.
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3. Change the remainder of shaders as follows:

Mercury Orange Brown

Venus Beige Yellow

Earth Blue

Mars Red Orange

Jupiter Yellow Green

Saturn Pale Yellow

Uranus Cyan

Neptune Aqua Blue

Pluto Bright Gray

Figure 3.10 shows the shading groups. Next you will apply shaders to

each of the planets.

4. Select a planet in the perspective window, and RMB click its corre-

sponding material in the Hypershade window to open a marking

menu. Drag up to highlight Assign Material to Selection and release

the button to select it. You can also MMB drag the material from the

Hypershade window to its planet, although assigning material in this

way is not preferable. Leave the moons the default gray color. When

you’re finished, you should have a scene similar to Figure 3.11.

Now that you’re done with that, you’re ready to animate! Just save this file, and if

you’ve enabled incremental save as recommended earlier, it won’t be replaced with subse-

quent saves. If you get lost in your animation and need to start fresh, you won’t have to

create everything from scratch again. You can just return to a previous version of the file

and start your animation again.

Figure 3.10

The Hypershade window with all the colored
planet shading groups

Figure 3.9

The Color Chooser window
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Creating the Animation
To begin this phase of the project, load the file Planets_v2.mb in the Scenes folder of 

the Solar_System project on the CD, or continue with your own scene file. The animation

you’ll be doing for the orbits is straightforward. Basically you will rotate the planets

around their own axes, then you’ll animate the moons around the planets, and finally

you’ll send the planets with their moons orbiting the sun.

The premise of this exercise deals with hierarchy and pivot points. A pivot point is an

object’s center of balance of sorts. Every object or node that is created in Maya has a pivot

point at its origin. Since most objects, such as the spheres you created for the planets, will

appear at the origin upon creation, their pivot points are automatically centered.

Once you move an object, as you have done to position the planets and moons, the

pivot point moves with it. Thus, all your planets’ and moons’ pivot points are already 

correctly positioned at the center of each planet and moon.

Now you’ll set up your scene file’s animation settings:

1. Press F2 to open the Animation menu set.

2. With the Range Slider, set your animation to go from 1 to 240.

3. Click the Animation Preferences icon ( ), click Settings, and set Time to 30 frames

per second, or NTSC video speed.

Figure 3.11

The shaded planets
in perspective view
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4. Verify that Up-Axis is set to Y and not Z. This ensures that you have designated the Y

axis to be pointing “up” in the perspective window or pointing out at you from the

monitor in the top view. “Y up,” as it’s called, is Maya’s default, but it never hurts to

make sure.

Mercury’s Rotation

Now you’re ready to animate Mercury’s rotation. Follow these steps:

1. Select Mercury first, and press E to activate the rotation manipulator. Press F to focus

on it in the perspective view, or zoom in on it manually.

2. Make sure you are on frame 1 of your animation range. You’ll place an initial

keyframe here for the first planet.

3. For Mercury, you’ll be setting your initial keyframe for the Y-axis rotation. In the Chan-

nel Box, click the attribute Rotate Y to select it and choose Animate ➔ Set Key. The

Rotate Y’s attribute box should turn orange, indicating a keyframe or other input if you

have followed the advice in the sidebar “Setting Keyframes.” If you have left it at its

defaults, Animate ➔ Set Key will set keys on all the attributes, turning them all orange.

4. With the Range Slider, go to frame 240. Grab the rotation manipulator handle by the

Y axis and turn it clockwise a few times to rotate the sphere.

5. Choose Animate ➔ Set Key with the Rotate Y attribute still selected in the Channel Box.

6. To playback your animation, you can scrub your Timeline. Scrubbing refers to using

the mouse to move the time marker back and forth to watch the animation playback

in a window. Click in the Timeline, hold down the left mouse button, and move your

cursor side to side to scrub in real time. You’ll see Mercury rotating around itself in

your active view panel.

Clicking so many things just to set two keyframes may seem like a lot of work, but

you’re doing this the long way right now; you’re not yet using any shortcuts or hot keys.

You’ll start using those for the next planet.

You have the self-rotation for Mercury worked out, and since there’s no moon for

Mercury, let’s get it orbiting the sun.

Choose Window ➔ Settings/Preferences ➔ Preferences to open the Preferences window.

Under Settings: Undo, check the circle for Undo to On (if it isn’t already), and set the Queue to

Infinite. Setting the Queue to Infinite takes a little more system memory, but it’s worth it. With

this configuration, you can undo (press Ctrl+Z or just Z) as many times as it takes to undo any

blunders. To close the Preferences window, click Save.
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Grouping Mercury for a New Pivot Point

You’ve learned that every object created in Maya is created with a pivot point around

which it rotates, from which or to which it scales, and which acts as the placement point

for its XYZ coordinates. If the pivot point for Mercury is already at the center of itself,

how can you rotate it around the sun?

One idea is to move its current pivot point from the center of itself to the center of the

sun. That would, however, negate its own rotation, and it will no longer spin around its

own center; so you can’t do that. What you need to do is to create a new pivot point for

this object by creating a new parent node above it in the hierarchy. For more on object

nodes and hierarchy, refer to the end of Chapter 2.

To create a new pivot point, follow these steps:

1. With Mercury still selected, choose Edit ➔ Group. The Channel Box displays the

attributes for the node called group1. In addition, the rotation manipulator handle

jumps from where it was originally, centered on Mercury, to the origin—where the

zero points of the X, Y, and Z axes collide. Figure 3.12 shows the new Mercury group

and its new pivot location.

You essentially created a new Maya object by grouping Mercury to itself, and hence

also created a new pivot point, placed by Maya at the origin by default. Since an object’s

manipulator always centers on its pivot point, yours jumped to the origin. That’s fortu-

nate for you, because that just happens to be the center of the sun, exactly where you need

it to be for Mercury to orbit it properly.

Figure 3.12

Grouping Mercury
to itself creates a

new pivot point at
the origin.
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2. Without unselecting Mercury, click the word group1 in the Channel Box and change

the name of this new group to Mercury_Orbit.

3. Now click anywhere in an empty space in your view window to unselect Mercury_Orbit.

Try selecting it again. Notice that when you click Mercury, you only select the planet and

not the new parent node Mercury_Orbit, the group that has its pivot point at the center

of the sun. This happens because you are in object selection mode.

4. Go back to frame 1 of your animation and set a keyframe for Mercury_Orbit’s Rotate

Y attribute by choosing Animate ➔ Set Key.

5. Go to frame 240, grab Mercury_Orbit’s rotate manipulator handle by the Y axis, and

spin it around the sun twice. You could also type 720 in the Rotate Y attribute field in

the Channel Box.

6. Choose Animate ➔ Set Key to set a keyframe at frame 240 for Mercury_Orbit. Scrub

your animation to play it back.

One down, eight to go.

Creating Venus

For your next planet, Venus, follow the same procedure as for Mercury, and animate it so

that it orbits itself. Then create a new pivot point by grouping it to itself (and calling the

new node Venus_Orbit). Last, animate Venus_Orbit to rotate around the sun.

Earth and the Moon

You will animate the third planet in much the same way, except that this time there is the

added complication of a moon. In addition, instead of choosing Animate ➔ Set Key to set

your keyframes, you’ll use the keyboard hot key S.

Whenever you press S and an attribute is highlighted in the Channel Box, you are essentially

choosing Animate ➔ Set Key. Make sure in the Set Key Options dialog box that you have

changed Set Keys On to All Keyable Attributes instead of the default All Manipulator Handles

and Keyable Attributes and that you’ve set Channels to From Channel Box instead of the

default All Keyable.

To select the group Mercury_Orbit, you need to switch into Hierarchy Mode by toggling its

icon (         ) on the Status line. Just remember to switch back to Object Mode (         ).
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To animate Earth and the moon, follow these steps:

1. Select Earth and give it its self-rotation animation as with Mercury, but this time select

the rotation channels in the Channel Box and press S instead of choosing Animate ➔

Set Key for rotation keyframes. Again, if you have left the Animate ➔ Set Key ❒ at its

defaults, pressing S will set keys for all attributes, but if you followed the advice given

previously, only the channels will be keyframed.

2. Select the moon and give it its own self-rotation animation by spinning it around

itself and keyframing it as you’ve just done with Earth.

3. To spin the moon around Earth, do what you did earlier in this chapter to spin a

planet around the sun. Group the moon to itself by choosing Edit ➔ Group and 

name it Moon_Orbit.

This time, however, you need the pivot point to be at the center of Earth and not at the

center of the sun, where it is currently. Follow these steps:

1. Turn on the grid snap, and then press the Insert key to activate the pivot point. The

moon’s manipulator changes from a rotation handle to the pivot point manipulator.

This manipulator acts just like the move manipulator, but instead of moving the

object, it moves the object’s pivot point.

2. Grab the yellow circle in the middle of the manipulator and move the pivot point to

snap it to the grid point located at the center of Earth (see Figure 3.13).

3. Press the Insert key again to return to the rotation manipulator for Moon_Orbit. At

frame 1, set a keyframe for the moon’s Y-axis rotation. Then, at frame 240, rotate the

moon about the Y axis and set a keyframe. Return to frame 1.

Figure 3.13

Moving the moon’s
pivot point to the

center of Earth
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G R O U P I N G  T H E  M O O N  W I T H  E A R T H

To create the animation of Earth’s orbit of the sun, you need to make sure that the moon

will also follow Earth around the sun. So, instead of just selecting Earth and grouping it to

itself as you’ve done for the other two planets, you need to include Moon_Orbit. Follow

these steps:

1. Select Earth and then Shift+click the group Moon_Orbit while in hierarchy mode 

to make sure you get the topmost node of the moon, and then choose Edit ➔ Group.

Name this Earth_Orbit. Remember, when you simply select either Earth or the moon

in object mode, the Earth_Orbit node is not selected. If you select Earth and then

Shift+click the moon, you do select both objects, but you will still not select

Earth_Orbit, the group that contains both these objects and has its pivot point at the

center of the sun. So make sure you select the right group.

2. Set a keyframe for Earth_Orbit’s Rotate Y attribute at frame 1 by highlighting Rotate

Y in the Channel Box and pressing S for the Set Key command. This assumes you

have changed the defaults in Animate ➔ Set Key ❒ as discussed earlier.

3. Go to frame 240, spin Earth and the moon around the sun a few times, and set a

keyframe there as well.

Now the first three planets are going around themselves and around the sun, with a

moon in there too. If you haven’t been saving your work, save it now. Just don’t save over

the un-animated version from before.

C R E A T I N G  T H E  O T H E R  P L A N E T S ’  M O O N S

Repeat this animation procedure for the remaining planets and moons, but leave out

Pluto for now.

A U T O  K E Y F R A M E

You can also use the Auto Keyframe feature when animating the planets and moons. Auto

Keyframe automatically sets a keyframe for any attribute that changes from a previously

set keyframe. For example, an initial keyframe for an attribute such as Y-Axis Rotation

If you find that one of your moons is left behind by its planet or that it’s no longer rotating

around the planet, you most likely made an error when grouping the moon and planet. Undo

until you’re at the point right before you grouped them, and try again. If that still doesn’t work,

start over from the earlier version of the file you saved just before you started animating it.

Make sure you use Hierarchy Mode (         ) when you click the moon object to select Moon_Orbit

and not just the moon sphere. Otherwise, you will lose the animation of the moon orbiting Earth.
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needs to be set at some point in the animation. The next time the Y-Axis Rotation is

changed, Maya will set a keyframe at the current frame automatically.

To turn on Auto Keyframe, click the Auto Keyframe icon ( ), which is to 

the right of the Range Slider. When the icon is red, Auto Keyframe is active.

To use Auto Keyframe to animate Mars’ moon orbiting Mars, follow these steps:

1. Turn on Auto Keyframe.

2. Start at frame 1. Select Mars’ moon and set a keyframe for its Y rotation by highlight-

ing Rotate Y in the Channel Box and pressing S.

3. Got to frame 240. Rotate the moon around Mars several times. Maya will automati-

cally set a frame for Y rotation at frame 240. Save your file.

Using the Outliner
Now, let’s look at how to use the Outliner to illustrate the hierarchies for the planets and

moons. When all is good and proper, the Outliner should look like Figure 3.14. Choose

Window ➔ Outliner and take a peek at what you have. If you haven’t yet named every-

thing properly, such as the moons, take this opportunity to do so.

Let’s take a look at the planet Mars and its layout in the Outliner to better understand

the hierarchy for all the planets. All the other planets should be laid out exactly like Mars

(except for the planets that have either one or no moons).

At the bottom of the hierarchy are Mars’ two moons, mars_moon and mars_moon2.

Each of those moons is spinning on its own pivot point. You then grouped each moon to

itself, creating the mars_moon_orbit and mars_moon2_orbit nodes, and you placed their

pivot points at the center of Mars to animate their orbits of Mars.

Mars is spinning on its own pivot point, but it needed another pivot point to be able

to orbit the sun. Since you needed to make the moons go with it around the sun, you

selected Mars, mars_moon_orbit, and mars_moon2_orbit (the top nodes of the moons

that circle the planet Mars) and grouped them all together, placing that pivot point at the

center of the sun. This node you called Mars_Orbit. This is the parent node since it is the

topmost node for this group. Where this parent node goes, so follow the children nodes

that are grouped under it.

Hierarchy such as this is a cornerstone of Maya animation. It is imperative to be com-

fortable with how it works and how to work with it.

Correcting Hierarchy Problems Using the Outliner
One of the most common problems you will run into with this project is a planet rotating

around the sun without its moon. The following steps will force you to make this error

with the planet Pluto, to illustrate how to fix it using the Outliner—as opposed to undoing

and redoing it as suggested earlier.

76 ■ chapter 3: Your First Maya Animation

Figure 3.14

The Outliner view 
of the planet 

hierarchies

4353c03.qxd  6/2/04  4:31 PM  Page 76



Go to Pluto, start the same animation procedure as outlined earlier, and then follow

these steps:

1. Create Pluto’s own rotation by spinning it around itself.

2. Do the same for its moon’s rotation.

3. Group the moon to itself and grid-snap the pivot point at the center of Pluto to create

the moon’s orbit of Pluto.

Once Pluto’s moon (pluto_moon) is orbiting Pluto, you’re ready to group the moon’s

orbit and Pluto together to create an orbit of the sun for them both.

4. Here is where you make your mistake. In object mode, select the sphere for Pluto’s

moon, and select the sphere for Pluto. Your error is that you are remaining in object

mode instead of switching to hierarchy mode.

5. Choose Edit ➔ Group to group them together, and call that new node Pluto_Orbit like

the others.

6. Animate Pluto_Orbit rotating around the sun.

7. Playback the animation.

Notice that the moon is no longer orbiting the planet. This is because you didn’t

include pluto_moon_orbit in your group Pluto_Orbit. The animation of the moon going

around Pluto is stored in that node, and since it is no longer attached to your Pluto_Orbit,

there’s no moon orbit of Pluto.

Figure 3.15 shows the hierarchy of Pluto and how it’s different from the other planets

(with Earth showing as an example). The moon’s orbit node has been left out of the

group.

Using the Outliner, you can easily fix this problem. You will place the

pluto_moon_orbit node under the Pluto_Orbit node. Go to frame 1 of the animation,

grab the pluto_moon_orbit node in the Outliner, and MMB drag it to the Pluto_Orbit

node so that it has a black horizontal line above and below it to show a connection, as in

Figure 3.16.

You have just grouped pluto_moon_orbit under Pluto_Orbit, a practice known 

as parenting. Now you need to parent pluto_moon under pluto_moon_orbit as well.

MMB drag pluto_moon onto pluto_moon_orbit. When you playback the animation,

you will see that the moon is rotating around the planet as Pluto and the moon both

orbit the sun. Now the layout in the Outliner for Pluto is similar to the other properly

working planets.

The file Planets_v3.mb in the Scenes folder of the Solar_System project on the CD will

give you an idea how this project should now look. The first five planet systems are

grouped and animated as reference, leaving the final four for you to finish.
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G R O U P I N G  T E R M I N O L O G Y

Grouping terminology can be confusing. Grouping Node A under Node B makes Node A a

child of Node B. Node B is now the parent of Node A. Furthermore, any transformation, or

movement, applied to the parent Node B will be inherited by the child Node A.

When you group Node A and Node B, both nodes become siblings under a newly created

parent node, Node C. This new node is created just to be the parent of Nodes A and B and is

otherwise known as a null node. To group objects, select them and choose Edit ➔ Group.

Parenting nodes together places the first selected node under the second selected node.

For example, if you select Node A, Shift+select Node B, and then choose Edit ➔ Parent, Node

A will group under Node B and become its child. This is the same procedure as MM dragging

Node B to Node A in the Outliner as you did with Pluto’s moon and Pluto itself.

Summary
The planet animation you created is based on a system of layering simple actions on top of

each other to achieve a more elaborate result. If you work slowly and in segments, anima-

tion is more straightforward to produce and generally is of a higher quality. Much of your

time in actual animation—as opposed to setup or modeling—will be spent adjusting the

small things. These small things give the scene life and character. You will find that finish-

ing 85 percent of a scene will take about 15 percent of the time. The remaining 85 percent

of the time goes into perfecting the final 15 percent of the scene.

You can add objects to a group by MMB dragging their listing onto the desired parent node

in the Outliner. You can also remove objects from a group by MMB dragging them out of the

parent node to a different place in the Outliner.
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