**What are polygons?**
- They are geometric shapes defined by vertices that create N-sided shapes.
- Polygons objects are made up of many individual polygons linked together at the vertices.

**Why use polygons?**
- They provide more precise results on flatter-shaped objects.
- They sacrifice render quality for increased system performance due to lower polygon counts.
- Not practical for high-curved objects or water/wave effects.
Polygon Models (part-2)

Vertices
A vertex is a point in 3D space. Three or more connected vertices make a face. Press F9 for Vertex Selection mode.

Selected Vertices

Edges
Edges connect vertices by drawing a straight line between them. A single edge can be moved, scaled or rotated. Press F10 for Edge Selection mode.

Selected Edges

Selected UVs

Quad

Selected Faces

Triangle

Faces
A face is made up of three or more connected edges. A face with three sides is a triangle, with four sides is a quad and with more than four sides is a n-gon. A face can be moved, scaled or rotated. Press F11 for Face selection mode.

UVs
UVs are the two-dimensional coordinates that are required to display or render a texture on a mesh. A UV directly corresponds to a vertex on the mesh. Press F12 for UV selection mode.
What are the various POLYGON functions?
- Sphere, Cube, Cylinder, Cone, Plane, Torus (Doughnut), Pyramid, Pipe
- **Combine (group)**
  - **Separate**
  - **Extrude**
  - **Flip triangle edge**
  - **Bridge**
  - **Collapse**
  - **Chamfer vertex**
  - **Extract**
  - **Subdivide proxy**
  - **Cut faces**
  - **Sculpt geometry**
  - **Reduce**
  - **Merge**
  - **Mapping...**
  - **Split polygon**
  - **Merge edge**
  - **Merge edge**

**Smooth** - increase (smoothen) object by increasing polygon count.

**Reduce** - decrease (roughen) object by decreasing polygon count.

**Bridge** - creates a bridge (link) between 2 sets of edges or faces (polygons).

**Chamfer vertex** - cuts an object's edge into a 45-degree angle(s).

**Collapse** - fold two or more faces (surfaces) onto each other, forming a point(s).

**Extract** - detach a face (or set of faces) from the parent object with an offset distance.
- Polygon smoothing causes UV coordinates.
- Polygon smoothing nicely interpolates world coordinate points.
- Polygon smoothing will **NOT** interpolate 2-point UV coordinates.
  - This causes skewed texture mapping on smoothed surfaces.
Polygon Models (part-5)

Merge example:

Chamfer example:
Polygon Models (part-6)
**What are NURBS?**
- They are geometric spline-based geometric objects derived from curves and surfaces approximated from the surface's control vertices.

**Why use NURBS?**
- They provide more precise curved results with better object shaping flexibility.
- They sacrifice render speed for increased render quality and realism.
- Quicker at rendering smooth surfaces and water/wave type effects compared to polygons.

**NURBS vs. Polygons:**
- Polygons are best thought as thin solid sheets cut and glued into shapes or objects.
- NURBS are best thought as single (or multiple) molding clay blocks formed to make shapes or objects.
What are the various NURBS functions?
- Sphere, Cube, Cylinder, Cone, Plane, Torus (Doughnut)
- **Revolve**
- **Loft** - Intersect surfaces - Insert isoparm(s)
- **Planar** - Untrim surface - Extrude surface
- **Extrude** - Attach surface - Rebuild surface
- **Birail** (1/2/3+) - Detach surface - Sculpt geometry
- **Bevel** - Open/Close surface - Surface editor (vertex)
- **Project curve onto surface**

**Loft** - creates a flat curved plane between 2 curved lines.

**Planar** - selected surfaces form one or more closed regions/loops (removes excess vertices).

**Birail** (1/2/3+) - creates a half-revolved object based on 2-rails (degree-0) and 1-3+ rider paths.

**Bevel** - similar to **CHAMFER** tool for polygons.

**Insert isoparm** - adds more divisions to a NURBS surface for curve editing and smoother surfaces.

**Rebuild surface** - recreate object with set # of **isoparm** lines for uniform surface structure.
NURBS (part-3)

Birail Tool (1 / 2 / 3+)

Birail 1

Birail 2

Birail 3+
Primitives
NURBS primitives are common geometric objects such as spheres, cubes, and cylinders. Primitives are often used as the foundation for other shapes.

Trim Surface
To create a trimmed surface, a closed Curve-on-Surface is required. There are various ways of creating these curves which will be discussed later in this chapter.

Extrude Surface
The Extrude Tool creates a surface by sweeping a cross-sectional profile curve along a path curve. The profile curve can be an open or closed curve, a surface isoparm, a Curve-on-Surface or a trim boundary. The extruded surface on this model creates a lip for the scooter surface and gives the illusion of depth.

Loft Surface
A Loft Surface is created when a surface is applied to a series of profile curves that define a frame. There must be at least two curves or surface isoparms and ideally the same parameterization for each curve, to achieve a clean surface. If the curves have the same curve degree and parameterization, the Loft Surface will have the same number of spans in the U direction.

Revolve Surface
The Revolve Tool creates a surface defined by a profile curve that revolves around a defined axis. The use of construction history is very useful to tweak the shape after the revolve operation. The front fender began as a revolved surface that was then scaled, deformed and finally trimmed. The firs and rims are simple revolves.
NURBS (part-5)
Use imported image files as rough outlines for object creation.
Subdivision Surfaces

- Greater control
- Good for modeling organic surfaces
- Relatively high storage space
- Allow for various levels of editing detail
Creating a Subdivision Surface
Creating a Subdivision Surface
Subdivision Surface Cube
Refine Subdivision Surface
Modify -> Convert
Splitting Polygons

**Purpose:**
- Allows you to divide a polygonal face to create new faces on an object
- Allows you to insert new vertices on an edge of an object

**Using it in Maya:**
- Draws a line across a face to split it into two new faces
- A line must start and end on an edge
- Each time it touches an edge a new face is created

A common use of the Split Polygon Tool is to divide a face in half. This is done with a tolerance of 100. However, the face can be split any way you want as long as the last vertex ends up on an edge.
Splitting Polygons
Step by Step process in Maya
Splitting Polygons
Splitting Polygons
Splitting Polygons
Splitting Polygons
Joining Objects

**Purpose:**
- Allows you to design individual parts and pieces of a model, then join them to make the model one whole entity

**Using it in Maya:**
- Objects must be combined to create a single object and must have their normals pointing in the same direction

The torso and arms are selected and ready to be combined. Mesh > Combine to do this. The three objects have been combined into one object. However, there are three separate shells.
Joining Objects

Step by Step process in Maya
Joining Objects
Joining Objects
Extruding Faces

**Purpose:**
- Allows you to extend the face or vertex of an object to obtain creative, desired effects by inserting new faces at the edges of the face being extruded

**Using it in Maya:**
- Extrusion is performed on the faces or vertices of objects
- **Face** – Made up of three or more connected edges
- An extruded face can be translated, scaled, and rotated
- Multiple faces can be selected at once to be extruded together
- Combine extrusion with “CV Curves” to “guide” the extrusion along a particular path
Extruding Faces

Step by Step process in Maya
Extruding Faces
Extruding Faces
Extruding Faces
Extruding Faces

[Image of Autodesk Maya software interface with a cube and menu options highlighted]
Extruding Faces
Extruding Faces
Extruding

1. Draw A Polygon

2. Select **FACE** Mode by holding down the right mouse button

3. Select **EXTRUDE** and the control axis will appear
3. Selecting of the control features on the right (move, scale or rotate) will let you apply different techniques to the current extrude.

4. After each transformation is applied, click extrude again to re-select the face and perform another transformation.

This shape is the result of performing a scale and then raising the face up using extrude.
Advanced Shapes Using Extrude
Duplicate Special (advanced technique)

- Copy object many times easily
- Add spacing between objects
- Apply transformations such as rotation to each new object created

This method was used to create the ramparts on the castle in the previous slide.
**Revolve**

- Can be used to create complex shapes from simple curves
- Great making shapes with smooth edges

1. Draw a curve on the screen. It is normally better to use a view other than perspective for this...

2. Go to **SURFACES -> REVOLVE** to find the revolve command. Just clicking it will revolve with the default settings, or click the small box for more options.
3. The options menu gives you more control over the revolve option. Changes these attributes can create a variety of different shapes from the curve.

4. The same object as before with a revolve of only 180 degrees instead of 360.
Loft

- Another way of making simple shapes
1. Create a curve the same way as in revolve
2. Attach the curves together using **EDIT CURVES -> ATTACH CURVES**
3. Copy the curve (use duplicate special if you wish), each separation will be a separation in the final object
4. After the curves are duplicated (and attached) go to **SURFACES -> LOFT** to loft the two surfaces together.
3. As you can see a surface is created.

4. Changing the options can affect the way a surface was created. As you can see here changing the section spans to "2" increases the divisions in the surface.

5. After all the surfaces are created they will still be individual. To complete the object you must go **EDIT NURBS -> ATTACH SURFACES**
Trim allows for sections of objects to be removed using a variety of methods, the method used here is by project curves onto the NURBS object.

1. First create a Nurb Sphere
2. Switch to Front View
3. Draw a curve using the same method as in Loft and Revolve slides
4. Project the curve onto the sphere by going to EDIT NURBS -> PROJECT CURVE ON SURFACE. Trim curves MUST exist to perform a trim. You can do this using intersection to create curves as well.
5. Select the Sphere and go to **EDIT NURBS -> TRIM TOOL**
6. Select the portion of the Sphere you want to keep and a yellow dot will appear.
7. Click enter and the trim will be completed.
Fillet Blend Surfaces

Fillet Blend Surfaces allows for two surfaces to be blended together using their ISOPARMS, used mostly for Nurbs objects.

1. Create two Nurbs objects

2. Select EDIT NURBS -> SURFACE FILLET -> FILLET BLEND TOOL
3. Switch to ISOPARMS select the first isoparm on the first object. Press *ENTER* then select the second isoparm on the second object and press *ENTER*.

A Fillet Blend will be created after the second enter is pressed.
Grouping and Parenting

- Objects in Maya are arranged in a hierarchy
- **grouping** - objects in group can be changed together or independently
  - new group node created
- **parenting** - parent object space is new world space of child
  - no new node is created
  - transforming parent also transforms child
Grouping

Select objects to group

Hypergraph (Window -> Hypergraph: Hierarchy)

Outliner (Window -> Outliner)

Ctrl-G or Edit -> Group
Grouping

Select group by
- clicking on group in hypergraph
- clicking on group in outliner
- clicking on the *Select by hierarchy* button and clicking on an object in the group
- clicking on object in group and using arrow keys to navigate hierarchy

Rotating the entire group

*Select by hierarchy* button
Parenting

- Useful for modeling skeletal structures
- Similar to grouping but parent is actual object rather than group node

Lamp composed of 2 cylinders and 2 cones

Drag child onto parent using middle mouse button
Parenting

- Rotating each object affects the objects below it in the hierarchy:
Material Qualities

- Ambient
- Diffuse
- Specular Highlights
- Color
- Transparency
- Bump
- Reflectivity
- Reflected Color
- Incandescence
- Glow
Material Types

- Lambert
- Phong
- PhongE
- Blinn
- Ramp
- Anisotropic
Shading Network

Shading group nodes are used to tell the renderer which materials, textures and lights will affect the final look of a surface.

Hypershade work area
What are Kinematic Chains?
- Basically many rigid body segments connected via joints.
- Such as robotic arms, mechanical linkages etc.
- Modeled with a Joint Chain hierarchy
- But how can we animate it?

Sources: [www.wikipedia.org](http://www.wikipedia.org)
[www.vgdotnet.com/blog/robot_arm.png](http://www.vgdotnet.com/blog/robot_arm.png)
Kinematic Chains and IK handles

- The hard way to do it is via Forward Kinematics (FK)
  - Specify where every joint will be at any given time.
  - Used for detailed arc motions
- Another method is Inverse Kinematics (IK)
  - Just specify where the lowest joint has to be and the rest will follow.
  - Great for goal-directed motion

Kinematic Chains and IK handles

- But how can we implement IK?
  - With IK Handles, Of Course!
  - The modeler decides where the handles are going to be placed.
  - An IK Handle starts at the parent joint and ends at any lower joint of the hierarchy

Sources:
http://www.alias.com/eng/support/studiotoolls/documentation/Animating/aboutAnimation10.html
Kinematic Chains and IK handles

- In Maya there are 3 IK handles available
  - Single Chain (SC) Handle
  - Rotate Plane (RP) Handle
  - Spline Handle.
- SC and RP Handles are used for Kinematic Chains
- Spline Handles are for curvy or twisty shapes, such as tails, necks, tentacles, etc.

Source: http://accad.osu.edu/%7Emidori/Materials/IK_solvers.html
Kinematic Chains and IK handles

- The difference between an SC Handle and RP Handle is that:
  - SC Handle's lower joint tries to reach the position and orientation of its IK handle.
  - RP Handle's lower joint only tries to reach the position of its IK handle.

Source: [http://accad.osu.edu/~midori/Materials/IK_solvers.html](http://accad.osu.edu/~midori/Materials/IK_solvers.html)
Templating Objects

- A way to simplify complex scenes by making certain objects unselectable.
- Better than hiding objects as you can still see the objects and use them as a grid.

Source: Maya Help "Template display"
1. Select Objects to template
2. Create a group (optional)
3. Display > Object Display > Template

Source: Maya Help "Template display"
To undo templating you must find the objects via the Outliner (or select the group if you created one and then):
Display > Object Display > UnTemplate

Source: Maya Help "Template display"
The End
Image Planes

Allows a guide image to be rendered into the scene to aid in modeling.

Useful when:
- already have a drawing/draft of the object you wish to model
- modeling an object that requires the proportions to be more exact

Image Planes 2

- First create a new camera for each orthographic perspective (Panels > Orthographic > New > top)
- Then add a new image plane for each (View > Image Plane > Import Image)
- Can scale and move each image plane independently (Select the image plane, go to the Channel box and select Inputs)
  - Select desired property (Center/Size/etc.) and move in perspective using middle mouse button
- Can also change alpha transparency of image plane

Image Planes 3